[Gluster-users] version mismatch

Wolfgang Pauli Wolfgang.Pauli at Colorado.EDU
Tue Nov 18 03:07:49 UTC 2008


I am having a really silly problem here. I tried to upgrade my glusterfs 
version to 1.3.12. When I try to mount the remote fs, I get this error:

2008-11-17 20:01:15 D [client-protocol.c:5103:client_protocol_handshake_reply] 
client: reply frame has callid: 424242
2008-11-17 20:01:15 E [client-protocol.c:5133:client_protocol_handshake_reply] 
client: SETVOLUME on remote-host failed: ret=-1 error=Version mismatch: 
client(1.3.12) Vs server (1.3.11)
2008-11-17 20:01:15 W [client-protocol.c:4784:client_protocol_cleanup] client: 
cleaning up state in transport object 0x9a061e0
2008-11-17 20:01:15 D [tcp.c:87:tcp_disconnect] client: connection 
[The END]

I tried to remove everything I could find on the server to make sure that there 
is no old files from the previous version left, but I still get this. What is 
even stranger is that when I run "glusterfs -V" on the server, it tells me the 
correct version 1.3.12.

I compiled glusterfs from the same tar ball on both client and server. 

I ran the make uninstall, also tried to remove things manually 
/usr/local/lib/gluster* foo/libgluster* /usr/local/sbin/gluster*

Where does it pick up this old version number???



More information about the Gluster-users mailing list