[Bugs] [Bug 1672480] Bugs Test Module tests failing on s390x

bugzilla at redhat.com bugzilla at redhat.com
Mon Mar 4 05:23:28 UTC 2019


--- Comment #53 from abhays <abhaysingh1722 at yahoo.in> ---
(In reply to Nithya Balachandran from comment #51)
> > 
> > 
> > I don't think so. I would recommend that you debug the tests on your systems
> > and post patches which will work on both.
> Please note what I am referring to is for you to look at the .t files and
> modify file names or remove hardcoding as required.

Yes @Nithya, We understood that you want us to continue debugging the tests and
provide patches if fix is found.
While doing the same, we were able to fix the ./tests/bugs/nfs/bug-847622.t
with the following patch:-

diff --git a/tests/bugs/nfs/bug-847622.t b/tests/bugs/nfs/bug-847622.t
index 3b836745a..f21884972 100755
--- a/tests/bugs/nfs/bug-847622.t
+++ b/tests/bugs/nfs/bug-847622.t
@@ -28,7 +32,7 @@ cd $N0

 # simple getfacl setfacl commands
 TEST touch testfile
-TEST setfacl -m u:14:r testfile
+TEST setfacl -m u:14:r $B0/brick0/testfile
 TEST getfacl testfile

Please check, if the above patch can be merged.

However, the test cases are still failing and only pass if x86 hash values are
provided(Refer to comment#8):-

We have tried modifying filenames in these test cases, but nothing worked.
We think that the test cases might pass if the behavior of the source code for
hash value calculation is changed to support s390x architecture as well.
Could you please look into the same?

You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.

More information about the Bugs mailing list