[Bugs] [Bug 1672480] Bugs Test Module tests failing on s390x

bugzilla at redhat.com bugzilla at redhat.com
Mon Mar 4 05:35:44 UTC 2019


Nithya Balachandran <nbalacha at redhat.com> changed:

           What    |Removed                     |Added
              Flags|                            |needinfo?(abhaysingh1722 at ya
                   |                            |hoo.in)

--- Comment #54 from Nithya Balachandran <nbalacha at redhat.com> ---

> However, the test cases are still failing and only pass if x86 hash values
> are provided(Refer to comment#8):-
> ./tests/bugs/glusterfs/bug-902610.t
> ./tests/bugs/posix/bug-1619720.t

Please provide more information on what changes you tried.

> We have tried modifying filenames in these test cases, but nothing worked.
> We think that the test cases might pass if the behavior of the source code
> for hash value calculation is changed to support s390x architecture as well.
> Could you please look into the same?

This seem extremely unlikely at this point. Like I said, the code will work
fine as long as the setup is not mixed-endian. As the test cases are the only
things that fail and that is because they use hard coded values, such a huge
change in the source code is not the first step.

You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.

More information about the Bugs mailing list