[Bugs] [Bug 1781003] Gluster: Unable to add bricks to volume/ is already part of a volume/ Transport End point is not connected.

bugzilla at redhat.com bugzilla at redhat.com
Tue Dec 17 02:47:38 UTC 2019


akshsy <akshayvijapur at gmail.com> changed:

           What    |Removed                     |Added
              Flags|needinfo?(akshayvijapur at gma |
                   |il.com)                     |
                   |needinfo?(srakonde at redhat.c |
                   |om)                         |

--- Comment #7 from akshsy <akshayvijapur at gmail.com> ---
Hi Karthik,

My new machine refers to new node in the cluster which has some bricks from
previous old cluster. I have tried to do xattrs but it is not helping. As i
told you  the  number of bricks are not sync. 


Node 1 : It is only node 1 brick.

Node 2 : It has both node 1 and node 2 brick.

I am not sure why these are not in sync. But i restarted glusterd on both the
nodes, Then 

Node 1: It has only 1 brick 
Node 2: It has only 1 bricks of node 1.

Now i have tried to add brick to node 2 and it is successful.


Node 1 : It has both node 1 and node 2 brick.

Node 2 : It has both node 1 and node 2 brick.

Any reason why bricks are not in sync as we dont want to restart glusterd as it
is heavy operation?

Any other solution ?


You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.

More information about the Bugs mailing list