[Gluster-users] does your samba work with 4.1.x (centos 7.5)

Kaleb S. KEITHLEY kkeithle at redhat.com
Fri Nov 9 19:57:49 UTC 2018

On 11/9/18 10:19 AM, Diego Remolina wrote:
> Hmmm yes and no...

Yes and no what?

That samba comes from the CentOS-Base/updates repo.

If you don't use the Storage SIG you will get glusterfs 3.8.4,
client-side only; also from the CentOS-Base/updates repo.

That samba's rpm (.spec file) says it Requires: GlusterFS > 3.4, but in
all likelihood it was built with GlusterFS 3.8.4 from the Base/updates repo.

But the original question was about EPEL, and there is no version of
Samba or GlusterFS in EPEL. Enable the EPEL repo and disable the
Base/updates repo and try `yumdownloader samba\*` or `yumdownloader
glusterfs\*`. You won't get anything.

And if we extrapolate to the CentOS Storage SIG, there's still no
version of Samba there either. It would be nice if there was, but there

> Have had problems with samba 4.7.x from Centos repos and Gluster
> 3.10.x when using plugin vfs gluster to access shares so I had to use
> fuse mounts and point samba to fuse mounts.
> I tried an upgrade to glusterfs 4.1.5 a couple days ago and samba
> worked with it but still using fuse mounts, not vfs gluster.
> A while back a combination of samba vfs plugin ans gluster broke the
> use of Autodesk Revit files stored in gluster. However since I am
> still running 3.10.12, I am not able to open any bug reports or
> anything given it is no longer supported. I was hopping to do that
> with gluster 4.1.5, but had to roll back to 3.10.12.
> These are my current rpms (one version behind in samba) from Centos:
> rpm -qa | grep samba
> samba-client-libs-4.7.1-6.el7.x86_64
> samba-common-4.7.1-6.el7.noarch
> samba-common-libs-4.7.1-6.el7.x86_64
> samba-4.7.1-6.el7.x86_64
> samba-vfs-glusterfs-4.7.1-6.el7.x86_64
> samba-libs-4.7.1-6.el7.x86_64
> samba-common-tools-4.7.1-6.el7.x86_64
> rpm -qa | grep gluster
> glusterfs-api-3.10.12-1.el7.x86_64
> glusterfs-3.10.12-1.el7.x86_64
> glusterfs-client-xlators-3.10.12-1.el7.x86_64
> centos-release-gluster310-1.0-1.el7.centos.noarch
> glusterfs-fuse-3.10.12-1.el7.x86_64
> glusterfs-server-3.10.12-1.el7.x86_64
> samba-vfs-glusterfs-4.7.1-6.el7.x86_64
> glusterfs-libs-3.10.12-1.el7.x86_64
> glusterfs-rdma-3.10.12-1.el7.x86_64
> libvirt-daemon-driver-storage-gluster-3.9.0-14.el7_5.8.x86_64
> glusterfs-cli-3.10.12-1.el7.x86_64
> Diego
> On Fri, Nov 9, 2018 at 10:09 AM Kaleb S. KEITHLEY <kkeithle at redhat.com> wrote:
>> On 11/9/18 8:12 AM, lejeczek wrote:
>>> hi guys
>>> I presume because 4.1.x has been in EPEL repo it is confirmed and
>>> validated to work 100% with default samba installation.
>> GlusterFS — any version — is _not_ in EPEL.
>> However it is in the CentOS Storage SIG.
>>> But, I'd prefer to here you guys say you ACTUALLY have your samba work
>>> 100% with 4.1.x. Anybody?
>> Nobody has built Samba in the CentOS Storage SIG with GlusterFS support.
>> Not for a long time anyway. The last time it was built was over four
>> years ago — for el6.
>> It would be great if someone in one of the Gluster, Samba, or CentOS
>> communities would start building it on a regular basis.
>> Any volunteers?
>> --
>> Kaleb
>> _______________________________________________
>> Gluster-users mailing list
>> Gluster-users at gluster.org
>> https://lists.gluster.org/mailman/listinfo/gluster-users



More information about the Gluster-users mailing list