[Gluster-users] geo replication, invalid slave name and gluster 3.5.1

Stefan Moravcik smoravcik at newsweaver.com
Tue Jul 15 09:38:05 UTC 2014

Hello Guys,

I have been trying to set a geo replication in our glusterfs test 
environment and got a problem with a message "invalid slave name"

So first things first...

I have 3 nodes configured in a cluster. Those nodes are configured as 
replica. On this cluster I have a volume created with let say name 
myvol1. So far everything works and looks good...

Next step was to create a geo replication off site.. So i followed this 

I had peered the slave server, created secret.pem was able to ssh 
without the password and tried to create the geo replication volume with 
the code from the documentation and got the following error:

on master:
gluster volume geo-replication myvol1 start

on master:
[2014-07-15 09:15:37.188701] E 
[glusterd-geo-rep.c:4083:glusterd_get_slave_info] 0-: Invalid slave name
[2014-07-15 09:15:37.188827] W [dict.c:778:str_to_data] 
[0x7f979e20a306] (-->/usr/lib64/libglusterfs.so.0(dict_set_str+0x1c) 
[0x7f97a322045c]))) 0-dict: value is NULL
[2014-07-15 09:15:37.188837] E 
[glusterd-geo-rep.c:3995:glusterd_get_slave_details_confpath] 0-: Unable 
to store slave volume name.
[2014-07-15 09:15:37.188849] E 
[glusterd-geo-rep.c:2056:glusterd_op_stage_gsync_create] 0-: Unable to 
fetch slave or confpath details.
[2014-07-15 09:15:37.188861] E [glusterd-syncop.c:912:gd_stage_op_phase] 
0-management: Staging of operation 'Volume Geo-replication Create' 
failed on localhost

there are no logs on slave what so ever
I also tried different documentation with "create push-pem" got the very 
same problem as above...

I tried to start the volume as node:/path/to/dir and also created a 
volume on slave and started as node:/slave_volume_name always a same 

Tried to search for a solution and found this 

It was different user with a very same problem... The issue was shown on 
IRC channel, but never answered..

This is a fresh install of 3.5.1, so no upgrade should be needed i 
guess... Any help solving this problem would be appreciated..

Thank you and best regards,

This email and any files transmitted with it are confidential and intended 
solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please reply to the sender 
indicating that fact and delete the copy you received.
In addition, if you are not the intended recipient, you should not print, 
copy, retransmit, disseminate, or otherwise use the information
contained in this communication. Thank you.

Newsweaver is a Trade Mark of E-Search Ltd. Registered in Ireland No. 
Registered Office: 2200 Airport Business Park, Kinsale Road, Cork, Ireland. 
International Telephone Number: +353 21 2427277.

More information about the Gluster-users mailing list