[Gluster-users] Remove Replica Pair issue.

Robert Moss Robert.Moss at GlobalGeophysical.com
Mon Jul 14 15:00:00 UTC 2014

Thank you sac,

That worked like a champ. I also ran the same command on brick 2 of the pair.

Hopefully I will be able to help out in the future. Thank you again.

Best regards,

Rob Moss

From: Sachidananda Urs [mailto:surs at redhat.com]
Sent: Monday, July 14, 2014 9:44 AM
To: Robert Moss; gluster-users at gluster.org
Subject: Re: [Gluster-users] Remove Replica Pair issue.

Hey Rob,

On 07/14/2014 07:59 PM, Robert Moss wrote:

Gluster Gurus,

I am having an issue removing a gluster replica pair. I have tried numerous different iterations of the command and get back 'Incorrect brick tx4-gluster1-10:/brick10 for volume gv0'
Here is the output of "gluster volume info":

Volume Name: gv0
Type: Distributed-Replicate
Volume ID: 176c0a15-c107-4bdc-9b00-df7e5c841374
Status: Started
Number of Bricks: 10 x 2 = 20
Transport-type: tcp
Brick1: tx4-gluster1-1:/brick1/brick
Brick2: tx4-gluster1-2:/brick1/brick
Brick3: tx4-gluster1-3:/brick1/brick
Brick4: tx4-gluster1-4:/brick1/brick
Brick5: tx4-gluster1-5:/brick1/brick
Brick6: tx4-gluster1-6:/brick1/brick
Brick7: tx4-gluster1-7:/brick1/brick
Brick8: tx4-gluster1-8:/brick1/brick
Brick9: tx4-gluster1-9:/brick1/brick
Brick10: tx4-gluster1-10:/brick1/brick
Brick11: tx4-gluster1-1:/brick2/brick
Brick12: tx4-gluster1-2:/brick2/brick
Brick13: tx4-gluster1-3:/brick2/brick
Brick14: tx4-gluster1-4:/brick2/brick
Brick15: tx4-gluster1-5:/brick2/brick
Brick16: tx4-gluster1-6:/brick2/brick
Brick17: tx4-gluster1-7:/brick2/brick
Brick18: tx4-gluster1-8:/brick2/brick
Brick19: tx4-gluster1-9:/brick2/brick
Brick20: tx4-gluster1-10:/brick2/brick
Options Reconfigured:
nfs.disable: off

I would like to remove gluster1-10 from the gluster cluster.
Here is my command:

gluster volume remove-brick gv0 replica 2 tx4-gluster1-10:/brick1 tx4-gluster1-10:/brick2 force

You are getting the command wrong here. You can remove the replica pairs, in your case the pairs are:

Brick9: tx4-gluster1-9:/brick1/brick
Brick10: tx4-gluster1-10:/brick1/brick

And your command would be:

gluster volume remove-brick gv0 replica 2 tx4-gluster1-9:/brick1/brick tx4-gluster1-10:/brick1/brick

And if I understand correctly you want to remove the host gluster1-10 from the cluster which is part of two replica pairs. So you will end up removing two replica pairs if you want to remove gluster1-10 from the cluster.


Here is the result:
volume remove-brick commit force: failed: Incorrect brick tx4-gluster1-10:/brick1 for volume gv0

I have tried a number of iterations here, using different names and trying tx4-gluster1-10 and 1-9 bricks. Nothing has worked so far.
This is a test setup so we don't care about data, we just need to learn.
We will probably not put the node back in after removal.
Any help would be greatly appreciated.
Thank you in advance.

Best regards,

Rob Moss


Gluster-users mailing list

Gluster-users at gluster.org<mailto:Gluster-users at gluster.org>


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20140714/b8dd0dd8/attachment.html>

More information about the Gluster-users mailing list