[Gluster-users] geo replication, invalid slave name and gluster 3.5.1

M S Vishwanath Bhat vbhat at redhat.com
Tue Jul 15 10:26:01 UTC 2014

On 15/07/14 15:08, Stefan Moravcik wrote:
> Hello Guys,
> I have been trying to set a geo replication in our glusterfs test 
> environment and got a problem with a message "invalid slave name"
> So first things first...
> I have 3 nodes configured in a cluster. Those nodes are configured as 
> replica. On this cluster I have a volume created with let say name 
> myvol1. So far everything works and looks good...
> Next step was to create a geo replication off site.. So i followed 
> this documentation:
> http://www.gluster.org/community/documentation/index.php/HowTo:geo-replication 
These are old docs. I have edited this to mention that it is old geo-rep 

Please refer to 
for latest distributed-geo-rep documentation.
> I had peered the slave server, created secret.pem was able to ssh 
> without the password and tried to create the geo replication volume 
> with the code from the documentation and got the following error:
> on master:
> gluster volume geo-replication myvol1 start
> on master:
> [2014-07-15 09:15:37.188701] E 
> [glusterd-geo-rep.c:4083:glusterd_get_slave_info] 0-: Invalid slave name
> [2014-07-15 09:15:37.188827] W [dict.c:778:str_to_data] 
> (-->/usr/lib64/glusterfs/3.5.1/xlator/mgmt/glusterd.so(glusterd_op_stage_gsync_create+0x1e2) 
> [0x7f979e20f1f2] 
> (-->/usr/lib64/glusterfs/3.5.1/xlator/mgmt/glusterd.so(glusterd_get_slave_details_confpath+0x116) 
> [0x7f979e20a306] (-->/usr/lib64/libglusterfs.so.0(dict_set_str+0x1c) 
> [0x7f97a322045c]))) 0-dict: value is NULL
> [2014-07-15 09:15:37.188837] E 
> [glusterd-geo-rep.c:3995:glusterd_get_slave_details_confpath] 0-: 
> Unable to store slave volume name.
> [2014-07-15 09:15:37.188849] E 
> [glusterd-geo-rep.c:2056:glusterd_op_stage_gsync_create] 0-: Unable to 
> fetch slave or confpath details.
> [2014-07-15 09:15:37.188861] E 
> [glusterd-syncop.c:912:gd_stage_op_phase] 0-management: Staging of 
> operation 'Volume Geo-replication Create' failed on localhost
> there are no logs on slave what so ever
> I also tried different documentation with "create push-pem" got the 
> very same problem as above...
> I tried to start the volume as node:/path/to/dir and also created a 
> volume on slave and started as node:/slave_volume_name always a same 
> result...
> Tried to search for a solution and found this 
> http://fpaste.org/114290/04117421/
> It was different user with a very same problem... The issue was shown 
> on IRC channel, but never answered..
> This is a fresh install of 3.5.1, so no upgrade should be needed i 
> guess... Any help solving this problem would be appreciated..
 From what you have described, it looks like your slave is not a gluster 
volume. In latest geo-rep, slave has to be a gluster volume. Now 
glusterfs does not support a simple directory as a slave.

Please follow new documentation and try once more.


Best Regards,

> Thank you and best regards,
> Stefan

More information about the Gluster-users mailing list