[Gluster-users] Folder disappeared on volume, but exists on bricks.

Juan José Pavlik Salles jjpavlik at gmail.com
Mon Dec 1 15:28:09 UTC 2014

Indeed, heal only works on replicated volumes, you are correct. Touching
production storages it's usually a scary thing I know, but restarting
gluster service shouldn't make the situation worse, it actually could help.
My recommendation is: look for a proper time and unmount the volumes, then
restart gluster services, try to mount the volumes again and look for the
missing files. If the files aren't visible from the mounted volumes then,
as far as I know, you will need to copy your data again.

2014-12-01 12:21 GMT-03:00 Peter B. <pb at das-werkstatt.com>:

> Am Mo, 1.12.2014, 16:15 schrieb Juan José Pavlik Salles:
> > Have you tried running the heal operation?
> No, I have not tried to play around unless I know what I'm doing ;)
> I'm trying to find something in the online documentation about such a
> case, but can't find anything :(
> I thought "heal" is for replicated glusterfs, but we're only using
> distributed [1]. This is a production storage, so I'm very very careful
> before I just try something ;)
> I haven't even dared to stop/restart the glusterd, since I wanted to ask
> here first.
> Thanks again,
> Pb
> == References:
> [1]
> https://access.redhat.com/documentation/en-US/Red_Hat_Storage/2.0/html/Administration_Guide/sect-User_Guide-Managing_Volumes-Self_heal.html

Pavlik Salles Juan José
Blog - http://viviendolared.blogspot.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20141201/ab6b4f2f/attachment.html>

More information about the Gluster-users mailing list