[Gluster-users] Volume creation fails with "prefix of it is already part of a volume"

Stroppa Daniele (strp) strp at zhaw.ch
Thu Aug 22 06:57:58 UTC 2013

HI Anand,

As Daniel mentioned already, I also tried to create a volume with only brick on separate nodes, i.e. # gluster volume create vol_icclab transport tcp gluster-node4.test:/mnt/brick1/vol_icclab gluster-node1.test:/mnt/brick1/vol_icclab, but I still get the same error.

Daniele Stroppa
Institute of Information Technology
Zürich University of Applied Sciences

From: Anand Avati <anand.avati at gmail.com<mailto:anand.avati at gmail.com>>
Date: Wed, 21 Aug 2013 23:23:14 -0700
To: Daniele Stroppa <strp at zhaw.ch<mailto:strp at zhaw.ch>>
Cc: "mueller at tropenklinik.de<mailto:mueller at tropenklinik.de>" <mueller at tropenklinik.de<mailto:mueller at tropenklinik.de>>, "gluster-users at gluster.org<mailto:gluster-users at gluster.org>" <gluster-users at gluster.org<mailto:gluster-users at gluster.org>>
Subject: Re: [Gluster-users] Volume creation fails with "prefix of it is already part of a volume"

This is intentional behavior. We specifically brought this because creating volumes with directories which are subdirectories of other bricks, or if a subdirectory belongs to another brick can result in dangerous corruption of your data.

Please create volumes with brick directories which are cleanly separate in the namespace.


On Wed, Aug 21, 2013 at 7:51 AM, Stroppa Daniele (strp) <strp at zhaw.ch<mailto:strp at zhaw.ch>> wrote:
Thanks Daniel.

I'm indeed running Gluster 3.4 on CentOS 6.4.

I've tried your suggestion, it does work for me too, but it's not an
optimal solution.

Maybe someone could shed some light on this behaviour?

Daniele Stroppa
Institute of Information Technology
Zürich University of Applied Sciences
http://www.cloudcomp.ch <http://www.cloudcomp.ch/>

On 21/08/2013 09:00, "Daniel Müller" <mueller at tropenklinik.de<mailto:mueller at tropenklinik.de>> wrote:

>Are you running with gluster 3.4?
>I had the same issue. I solved it by deleting my subfolders again and then
>create new ones. In your case brick1 and brick2.
>Then create new subfolders in the place,ex.: mkdir /mnt/bricknew1  and
>/mnt/bricknew2 .
>This solved the problem for me, not knowing why gluster 3.4 behave like
>Good Luck
>EDV Daniel Müller
>Leitung EDV
>Tropenklinik Paul-Lechler-Krankenhaus
>Paul-Lechler-Str. 24
>72076 Tübingen
>Tel.: 07071/206-463, Fax: 07071/206-499
>eMail: mueller at tropenklinik.de<mailto:mueller at tropenklinik.de>
>Internet: www.tropenklinik.de<http://www.tropenklinik.de>
>Von: gluster-users-bounces at gluster.org<mailto:gluster-users-bounces at gluster.org>
>[mailto:gluster-users-bounces at gluster.org<mailto:gluster-users-bounces at gluster.org>] Im Auftrag von Stroppa Daniele
>Gesendet: Dienstag, 20. August 2013 21:51
>An: gluster-users at gluster.org<mailto:gluster-users at gluster.org>
>Betreff: [Gluster-users] Volume creation fails with "prefix of it is
>part of a volume"
>Hi All,
>I'm setting up a small test cluster: 2 nodes (gluster-node1 and
>gluster-node4) with 2 bricks each (/mnt/brick1 and /mnt/brick2) and one
>volume (vol_icclab). When I issue the create volume command I get the
>following error:
># gluster volume create vol_icclab replica 2 transport tcp
>volume create: vol_icclab: failed: /mnt/brick1/vol_icclab or a prefix of
>is already part of a volume
>I checked and found this [1], but in my case the issue it's happening when
>creating the volume for the first time, not after removing/adding a brick
>a volume.
>Any suggestions?
>Daniele Stroppa
>Institute of Information Technology
>Zürich University of Applied Sciences

Gluster-users mailing list
Gluster-users at gluster.org<mailto:Gluster-users at gluster.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20130822/a8ab2c3b/attachment.html>

More information about the Gluster-users mailing list