[Gluster-users] Automount using /net/<brickname> in Glusterfs 3.1?

Burnash, James jburnash at knight.com
Fri Nov 19 20:25:02 UTC 2010

Hi Jacob.

The link you gave me was the page I was referring to in my post - that's not what I need in terms of function or configuration, so no help to me, unfortunately.

What I'm asking for is - what do I need to do on the client to automount a Gluster NFS share without specifically mounting it using the mount command - but instead using /net/<brickname>/<sharename> syntax to automount and access the directory.

This is a crucial part of the client configuration, and cannot be changed in our current environment.

Any further help is appreciated.


James Burnash, Unix Engineering
T. 201-239-2248 
jburnash at knight.com | www.knight.com

545 Washington Ave. | Jersey City, NJ

-----Original Message-----
From: Jacob Shucart [mailto:jacob at gluster.com] 
Sent: Thursday, November 18, 2010 6:13 PM
To: Burnash, James; gluster-users at gluster.org
Subject: RE: [Gluster-users] Automount using /net/<brickname> in Glusterfs 3.1?


Did you follow the instructions in:


Please let me know if something in those instructions was not working.
Thank you!


-----Original Message-----
From: gluster-users-bounces at gluster.org
[mailto:gluster-users-bounces at gluster.org] On Behalf Of Burnash, James
Sent: Thursday, November 18, 2010 9:13 AM
To: gluster-users at gluster.org
Subject: [Gluster-users] Automount using /net/<brickname> in Glusterfs


I'm running Glusterfs 3.1.01 on Centos 5.2. I have 2 bricks setup as
mirrored and distributed, created using the 3.1 gluster commands. They all
work fine for client mounts and NFS mounts on the client of the form:
 mount -t nfs <brickname>:/mytest /mytest.

I've gone through all the Gluster documentation about automatic mounting -
/etc/fstab entries, etc. I did find some information on entries needed for
map files - but nothing I've tried has worked for automounting a Glusterfs
NFS share with this syntax:

cd /net/<brickname>/mydirectory

The command returns successfully, but a subsequent "mount" command shows
that this automount directory is actually writing to "/" on the client.

This is the syntax used everywhere in house so that explicit NFS mounts
aren't needed in the /etc/fstab of every machine, and so there is no
dependency on those mounts at boot time.

Has anybody tried this syntax, and if so what did you have to configure to
use autofs or amd daemons to perform this activity?

James Burnash, Unix Engineering

This e-mail, and any attachments thereto, is intended only for use by the
addressee(s) named herein and may contain legally privileged and/or
confidential information. If you are not the intended recipient of this
e-mail, you are hereby notified that any dissemination, distribution or
copying of this e-mail, and any attachments thereto, is strictly
prohibited. If you have received this in error, please immediately notify
me and permanently delete the original and any copy of any e-mail and any
printout thereof. E-mail transmission cannot be guaranteed to be secure or
error-free. The sender therefore does not accept liability for any errors
or omissions in the contents of this message which arise as a result of
e-mail transmission.
its discretion, monitor and review the content of all e-mail
communications. http://www.knight.com

More information about the Gluster-users mailing list