[Gluster-users] connection refused with AFR single process (1.3.8pre)

Ilan Berci Ilan.Berci at shoutresearch.com
Wed Nov 19 15:06:34 UTC 2008

Dear Glusterfs experts, 

Situation: I am here sitting in the server room which is colder than my fridge surrounded by loud windows machines all around me that keep blinking their obnoxious flashing lights at me just to drive me crazy.  I am a server side developer that works on linux and know next to nothing about ops (or administering linux) but have somehow found myself in here deploying linux servers for various tasks (we are a small company).  I am looking for a simple afr between some of my application servers for various data that we don't keep in our dbs.

Here is the situation

- glusterfs 1.3.8pre  
- running on Debian 4.0r5  
- retrieved and installed from apt-get with NO modifications

- running the script AFR single process : http://www.gluster.org/docs/index.php/AFR_single_process
- ONLY modifications to the script are the machine names.
- I run glusterfs EXACTLY as it states below the example:  glusterfs -f client.vol /mnt/glusterfs

I am getting a connection refused to the other host when I check the logs.. The FAQ on this error informs me to telnet from machine1 to machine2 on port 6996 whereby I get the same error.  (But if I use the regular port of 23 I get in fine) so I assume that process is not binding to the port properly.  

- The mount is fine on both machines and fuse (also deployed with apt-get) is loaded when glusterfs starts.  
- The files are moving fine between the posix directories and the mount points.  

- I wiped the firewalls on both boxes and tracerouted to make sure that there was indeed only ONE hop between both machines.

I then started grasping at straws and then tried running glusterfs and glusterfsd (which to my understanding is not needed with builds >= 1.3.8) and I get the same results.

If I do an nmap on localhost, I don't see anything sticking to port 6996, 
If I do an nmap from the outside interface, I still don't see anything on port 6996 (my understanding is that the daemon is listening on all interfaces by default so this doesn't surprise me)

- I tried specifying the port and interface explicitly in the .vol file only to get the same results.

Besides this, I think that glusterfs is a work of art.. It's very straight forward, well documented, and a joy to work with..   The fact that I don't have to compile anything into the kernel is great as well.. :)

Any help on this would be greatly appreciated.. 


More information about the Gluster-users mailing list