[Gluster-users] symbolic link problems

Anand Avati avati at zresearch.com
Mon Nov 17 18:29:29 UTC 2008

There is a bug fix in self-healing symlinks in patch-628. Can you try the
revision off tla? I tried to recreate a similar scenario as you mentioned
and things worked fine for me. The log message there too has been fixed (it
was not right to delete files in that case from the backend). Thank you for


2008/11/17 Keith Freedman <freedman at freeformit.com>

> so I got a strange error in gluster logs telling me that I need to
> delete a directory (tree) from all but the preferred node.
> gluster 1.4.0qa57
> so I deleted the thing from the undelying filesystem on one of my AFR'ed
> nodes
> I did the find command and it mostly rebuilt and autohealed.
> however, it got hung up anytime it ran into a symlink to a file that
> either doesn't exist OR
> does exist but the destination file exists outside of the underlying
> filesystem.
> Either seems to be pretty undesirable.
> I presume this is a bug.
> Keith
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20081117/a4e985ec/attachment.html>

More information about the Gluster-users mailing list