[Bugs] [Bug 1694010] peer gets disconnected during a rolling upgrade.

bugzilla at redhat.com bugzilla at redhat.com
Mon Apr 1 08:04:41 UTC 2019


--- Comment #5 from hari gowtham <hgowtham at redhat.com> ---
(In reply to Atin Mukherjee from comment #3)
> > When we do a rolling upgrade of the cluster from 3.12, 4.1 or 5.5 to 6, the upgraded node goes into disconnected state. 
> Isn't this only seen from 3.12 to 6 upgrade?

No, Atin. I issue happened with all the versions.
It could as well be some network issue with the machines I tried it on.
Not sure of it.

The point to note here is: some times just a glusterd restart fixed and 
in some scenarios it needed a iptables flush followed with glusterd restart.

But I found that the iptables flush with glusterd restart fixed it in every
scenario i tried.

I could find time to debug this further.

You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.

More information about the Bugs mailing list