[Gluster-users] set: failed: Quorum not met. Volume operation not allowed.

WK wkmail at bneit.com
Wed Aug 26 22:45:44 UTC 2020

So we migrated a number of VMs from a small Gluster 2+1A volume to a 
newer cluster.

Then a few days later the client said he wanted an old forgotten file 
that had been left behind on the the deprecated system.

However the arbiter and one of the brick nodes had been scraped, leaving 
only a single gluster node.

The volume I need uses shards so I am not excited about having to piece 
it back together.

I powered it up the single node and tried to mount the volume and of 
course it refused to mount due to quorum and gluster volume status shows 
the volume offline

In the past I had worked around this issue by disabling quorum, but that 
was years ago, so I googled it and found list messages suggesting the 

gluster volume set VOL cluster.quorum-type none
gluster volume set VOL cluster.server-quorum-type none

However, the gluster 6.9 system refuses to accept those set commands due 
to the quorum and spits out the set failed error.

So in modern Gluster, what is the preferred method for starting and 
mounting a  single node/volume that was once part of a actual 3 node 



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gluster.org/pipermail/gluster-users/attachments/20200826/7edd98a8/attachment.html>

More information about the Gluster-users mailing list