[Gluster-users] gluster over vdo, problem with gfapi

Strahil Nikolov hunter86_bg at yahoo.com
Thu Aug 13 06:06:03 UTC 2020

I don't  think it is VDO, but I can be wrong.

My ovirt  setup is VDO + Gluster v7.7 + CentOS 7.8 . I tested  libgfapi a long time ago and it worked.
If you wish you can ask in the ovirt users' mailing list how qemu is using libgfapi.

Best Regards,
Strahil Nikolov

На 13 август 2020 г. 7:19:49 GMT+03:00, dm <dm at belkam.com> написа:
>btw, all I wrote before was about raw file format,
>if it is qcow2 then, using gfapi:
>  virsh create /kvmconf/stewjon.xml
>error: Failed to create domain from /kvmconf/stewjon.xml
>error: internal error: process exited while connecting to monitor: 
>[2020-08-13 04:17:37.326933] E [MSGID: 108006] 
>[afr-common.c:6073:__afr_handle_child_down_event] 0-pool-replicate-0: 
>All subvolumes are down. Going offline until at least one of them comes
>back up.
>[2020-08-13 04:17:47.220840] I [io-stats.c:4054:fini] 0-pool: io-stats 
>translator unloaded
>2020-08-13T04:17:47.222064Z qemu-kvm: -drive 
>Could not read qcow2 header: Invalid argument
>very interesting...
>only problem here- should I report this to qemu, gluster or vdo? :-(
>13.08.2020 08:14, Dmitry Melekhov пишет:
>> 13.08.2020 07:31, Strahil Nikolov пишет:
>>> I ment dis you use C7 with Gluster 7 (or older) or C7 with the new 
>>> Gluster 8.
>> Frankly, I don't know what you mean by C7.. :-(
>>> Anyways,
>>> if it worked before , it should run now - open an issue in github
>>> I guess someone  from the devs will take a  look.
>> No, it never worked...
>> But opening issue is good idea, thank you!

More information about the Gluster-users mailing list