[Gluster-users] Missing glusterfs.so (Gluster + Samba-VFS under Ubuntu)

Neil Richardson neilr at ieee.org
Sun Nov 25 15:39:43 UTC 2018

Hi, guys.  I'm new to all of this and need some help with a problem
I've been banging my head against for a while.  (Tried
troubleshooting, checking logs, and lots of Googling for a few weeks
now, but just keep hitting dead ends.)

Missing file `/usr/lib/x86_64-linux-gnu/samba/vfs/glusterfs.so`, as
evidenced by error messages like these:

[2018/11/18 07:56:42.551587,  0] ../lib/util/modules.c:49(load_module)
  Error loading module
/usr/lib/x86_64-linux-gnu/samba/vfs/glusterfs.so: cannot open shared
object file: No such file or directory
[2018/11/18 07:56:42.551652,  0]
  error probing vfs module 'glusterfs': NT_STATUS_UNSUCCESSFUL
[2018/11/18 07:56:42.551694,  0]
  smbd_vfs_init: vfs_init_custom failed for glusterfs
[2018/11/18 07:56:42.551729,  0]
  vfs_init failed for service music

I was able to get a simple Gluster+Samba+CTDB cluster working enough
so that my Windows machines could see a read-only share, and it
seemed that if one Gluster node went offline the other would
(eventually) pick up so that the share remained available.  However
I read that samba-vfs-glusterfs would allow a more seamless
transition when a Gluster node goes down, and also allow Samba to
talk directly to the Gluster storage without having to go through
FUSE.  However all of the documentation and tutorials I can find are
either for non-Ubuntu systems or doesn't work (obsolete versions,
PPA not found, etc).

Basically I've done this (representative sample because my full
changelog and automation scripts would be too lengthy):
1) Gluster/Samba/CTDB config, but without the ZFS RAID-1 configuration
2) Add and configure `samba-vfs-modules`

3) Try to add/pin André Bauer's custom PPA to get any customized
versions that might be needed


I also tried a couple permutations of 'apt get' to see if the
different packages were installing differently based on what other
packages were installed, but I haven't found the magic sequence yet.

It looks like glusterfs-common has a "libglusterfs.so" for Ubuntu 18
and Ubuntu 16, but that package is already installed and I'm still
getting the error so there's something else I'm missing.

Samba 4.7.6-UBUNTU
glusterfs 4.1.2

I can't tell if this is a Gluster problem or a Samba problem, but I
figure I can't be the only Gluster user trying to set up this
configuration (and having this problem) so I'm starting here first.
Can someone please give me a clue what direction I should be looking in?

Thank you,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 884 bytes
Desc: OpenPGP digital signature
URL: <http://lists.gluster.org/pipermail/gluster-users/attachments/20181125/2f365790/attachment.sig>

More information about the Gluster-users mailing list