[Gluster-users] Strange behavior after rebalance

Jordan Willis jwillis0720 at gmail.com
Sun Jan 8 03:09:05 UTC 2017


I just added a new brick and then rebalanced. After I did that, I had some strange behavior on our cluster.

I was using a python script that did this on some nodes. 

import matplotlib
ImportError:libpng16.so.16: cannot open shared object file: No such file or directory

Which is weird because I listed it on the master node and it was there. I then logged in directly to each node that was “missing” the file and sure enough I got the same error. However, after I did:

$ls -l /mypython/lib/path/libpng16.so.16
/mypython/lib/path/libpng16.so.16 -> libpng16.so.16.22.0

I tried this script again and it worked! So this issue was just resolved by ls’ing the “missing” file. Is there a glusterfs explanation for this? Why is the file “missing” until I ask the shell to ls the file. These  nodes just mount my volume using mount -t glusterfs mymainnode:/brick, nothing too weird.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.gluster.org/pipermail/gluster-users/attachments/20170107/8cfc23a6/attachment.html>

More information about the Gluster-users mailing list