[Gluster-users] GlusterFS and NFS issues

deZillium dezillium at dezillium.com
Wed Oct 5 13:49:48 UTC 2016


I can't, for the life of me, get NFS mounts working from clients. Any 
help is greatly appreciated.

OS: Debian 8.6

GlusterFS 3.8.4-1 installed using the GlusterFS Debian repos.

Mounting using the native (glusterfs) client works but not as fast as I 
would like it to, so I have to use NFS.

This is the result of the mount command:

root at 1:~# mount -vvv -t nfs -o mountvers=3 server2:/shared /mnt
mount.nfs: timeout set for Wed Oct  5 16:32:30 2016
mount.nfs: trying text-based options 'mountvers=3,addr='
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: portmap query retrying: RPC: Program not registered
mount.nfs: prog 100005, trying vers=3, prot=6
mount.nfs: trying prog 100005 vers 3 prot TCP port 38465
mount.nfs: mount(2): No such file or directory
mount.nfs: mounting client2:/shared failed, reason given by server: No 
such file or directory

showmount -e server2:

Export list for server2:

This is the volume info:

Volume Name: shared
Type: Replicate
Volume ID: a9dc73eb-1fa6-460b-a60b-f2d3ab9672c3
Status: Started
Snapshot Count: 0
Number of Bricks: 1 x 3 = 3
Transport-type: tcp
Brick1: server3:/path/shared
Brick2: server2:/path/shared
Brick3: server1:/path/shared
Options Reconfigured:
nfs.addr-namelookup: off
cluster.readdir-optimize: on
server.event-threads: 4
client.event-threads: 4
cluster.lookup-optimize: on
performance.client-io-threads: on
performance.cache-refresh-timeout: 60
performance.cache-size: 512MB
auth.ssl-allow: client1,client2
server.ssl: on
client.ssl: on
transport.address-family: inet
performance.readdir-ahead: on
nfs.disable: off
nfs.export-volumes: on

(also tried with nfs.rpc-auth-allow 192.168.1.* and any)

volume status

Status of volume: shared
Gluster process                             TCP Port  RDMA Port  Online  Pid
Brick server3:/path/shared 49152     0          Y       742
Brick server2:/path/shared                                          
49152 0          Y       10527
Brick server1:/path/shared                                          
49152 0          Y       30175
NFS Server on localhost                     2049 0          Y       10978
Self-heal Daemon on localhost               N/A N/A        Y       10559
NFS Server on server3        2049      0          Y       1033
Self-heal Daemon on server3 N/A       N/A        Y       778
NFS Server on server1        2049      0          Y       30466
Self-heal Daemon on server1 N/A       N/A        Y       30212

Task Status of Volume shared
There are no active volume tasks

nfs.log on GlusterFS servers shows nothing suspicious (just a wrong 
version error, which goes away when manually setting the version when 
trying to mount).

Tried restarting nfs-common, rpcbind, stopping and starting the volume, 
restarting GlusterFS servers...nothing makes the volume show up on the 
client when using NFS. Again, for clarity, mounting with -t glusterfs 
works OK, writing and reading files works.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.gluster.org/pipermail/gluster-users/attachments/20161005/dc1df2bc/attachment.html>

More information about the Gluster-users mailing list