[Gluster-users] Peers moving to disconnected state while running rebalance on a replica volume

Suneel Gali suneelgali at outlook.com
Tue Jun 16 10:57:27 UTC 2015

Thanks Atin for the quick reply. Appreciated.

Date: Tue, 16 Jun 2015 16:13:01 +0530
Subject: Re: [Gluster-users] Peers moving to disconnected state while running rebalance on a replica volume
From: atin.mukherjee83 at gmail.com
To: suneelgali at outlook.com
CC: gluster-users at gluster.org

This is a known issue. Clusters crashed on the node which is showing disconnected. The fix will be released in 3.7.2

Sent from one plus one
On Jun 16, 2015 4:06 PM, "Suneel Gali" <suneelgali at outlook.com> wrote:

Hi Team,

Recently I started working glusterfs and created the following home setup:

Total nodes: 4


I created a replica volume (Name: replvol) on nodes gluster02 & g2-node2. I was able to mount the volume on my client vm and copy some files.
Now I created 2 bricks (one each on g2-node3 & node4) and ran add-brick on the replica volume. The bricks got added to the volume and the info is listed in replvol.info file.
Even at this stage the peer status shows that the peers are in cluster and connected.

Once I run: 
                             gluster volume rebalance replvol start


I see that the status of the peers (only g2-node3 and g2-node4)  are moving to "disconnected" and the status of g2-node2 is still "connected".

If I stop the volume and restart the nodes, they are getting back connected. Once again if I run rebalance, they are moving to disconnected state.

As I am not sure which specific files to share, so I am attaching the logs from gluster02, g2-node3 and g2-node4.

All nodes are running CentOS 7.1.1503 and glusterfs: 3.7.1
No issues with connectivity between the nodes. 

I also have a distributed volume up and running. I was able to add-bricks to the distributed volume and rebalance.

Any help to troubleshoot the issue will be appreciated.




Gluster-users mailing list

Gluster-users at gluster.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.gluster.org/pipermail/gluster-users/attachments/20150616/90a215ef/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: screenshot.JPG
Type: image/jpeg
Size: 62880 bytes
Desc: not available
URL: <http://www.gluster.org/pipermail/gluster-users/attachments/20150616/90a215ef/attachment.jpe>

More information about the Gluster-users mailing list