[Gluster-users] Solaris 11 x86 Won't Compile

Niels de Vos ndevos at redhat.com
Thu Jun 4 19:45:09 UTC 2015

On Thu, Jun 04, 2015 at 04:17:42PM +0100, Ian Prideaux wrote:
> Hi All,
> I've tried 3.6.3 & 3.7.1 and I can't get either to compile (I've not yet
> tried 3.5.4, I don't really want to be running software that's two
> versions out-of-date).

3.5.4 only was made available yesterday, it is actually the most recent
release that was made ;-)

> I've done a clean install in a VM.
> I've got all the updates from https://pkg.oracle.com/solaris/support/
> I've installed gcc, flex & bison.
> I've compiled & installed userspace-rcu-0.8.7.
> I've set PKG_CONFIG_PATH=/usr/loca/lib/pkgconfig (because configure need
> to be told where the urcu libraries were).
> configure runs OK.
> However gmake stops early with errors.
> Both sets of errors look very different, and it looks like errors in the
> source code.
> Does anyone have any ideas how I can get this working? Alternatively
> does anyone know how I can achieve similar results with Oracle Cluster 4.2?
> Thanks.
> 3.6.3 says:

I'll skip this, lets look at the 3.7.1 version for now.

> 3.7.1 says:
> common-utils.c: In function ‘gf_canonicalize_path’:
> common-utils.c:2659:9: error: implicit declaration of function ‘bzero’
> [-Werror=implicit-function-declaration]
>          bzero (path, strlen(path));
>          ^
> common-utils.c:2659:9: warning: incompatible implicit declaration of
> built-in function ‘bzero’ [enabled by default]

From 'man 3 bzero' on Fedora 22:

       4.3BSD.    This   function   is   deprecated   (marked   as  LEGACY  in
       POSIX.1-2001): use memset(3) in new programs.  POSIX.1-2008 removes the
       specification of bzero().

Replace it with a matching memset()?

> common-utils.c: In function ‘gf_interface_search’:
> common-utils.c:3005:17: error: implicit declaration of function ‘index’
> [-Werror=implicit-function-declaration]
>                  pct = index(host,'%');
>                  ^
> common-utils.c:3005:23: warning: incompatible implicit declaration of
> built-in function ‘index’ [enabled by default]
>                  pct = index(host,'%');
>                        ^

From 'man 3 index' on Fedora 22:

       4.3BSD; marked as LEGACY in  POSIX.1-2001.   POSIX.1-2008  removes  the
       specifications of index() and rindex(), recommending strchr(3) and str‐
       rchr(3) instead.

Seems index() is old too and should be replaced.

These are only two errors, probably the first that got hit. I think it
is well possible that more compile errors are awaiting you.

You can file a bug for this so that we can send patches for this:


If you are comfortable writing patches, you can attach them to the bugs
or to an email. However, we would most appreciate patches sent to our
Gerrit review tool, the Simplified Development Workflow explains how to
do that:


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 181 bytes
Desc: not available
URL: <http://www.gluster.org/pipermail/gluster-users/attachments/20150604/4aaa0ca8/attachment.sig>

More information about the Gluster-users mailing list