[Gluster-users] Debian jessie don't mount glusterfs at boot time (server and client on the same machine)

NOC - IP·RED noc at ipred.com.ar
Mon Jul 13 20:46:35 UTC 2015

-----Mensaje original-----
De: Vijay Bellur [mailto:vbellur at redhat.com] 
Enviado el: miércoles, 01 de julio de 2015 09:06 p.m.
Para: NOC - IP·RED; gluster-users at gluster.org
Asunto: Re: [Gluster-users] Debian jessie don't mount glusterfs at boot time
(server and client on the same machine)

On Monday 29 June 2015 09:42 PM, NOC - IP·RED wrote:
> Hello,
> This is my first time posting in the list.
> I’ve started to build a glusterfs system and everything is working 
> pretty good but I can’t achieve to mount the glusterfs volumen at boot
> I looked severals websites and tried lots of thing but I can’t get it
> After the box boots I can do “mount –a” and mount every glusterfs in 
> /etc/fstab without no problem.
> root at ipred01:/etc/glusterfs# gluster --version
> glusterfs 3.5.2 built on Mar 23 2015 14:42:50
> Repository revision: git://git.gluster.com/glusterfs.git
> Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
> GlusterFS comes with ABSOLUTELY NO WARRANTY.
> You may redistribute copies of GlusterFS under the terms of the GNU 
> General Public License.
> Could you please land me a hand on it?

>Does your entry in fstab contain _netdev? It would be necessary to mount
glusterfs successfully at boot time.

Dear  Vijay,
Yes, I have _netdev in my fstab file. Perhaps, GlusterFS-Servers starts
after mount-all?, I mean debían tries to mount the volume before the
glusterfs daemon starts.
I've tried to change glusterfs daemon to start even earlier but it continues
without no mounting at boot time.
If I log in, then do a mount -a, It mounts perfectly.
Running mount -a in rc.local, don't work yet.

Do you know any other work around to fix it up?

Thanks in advance.


More information about the Gluster-users mailing list