[Gluster-users] O_DIRECT (I think) again

Anand Avati avati at gluster.org
Fri Feb 13 15:55:14 UTC 2015

O_DIRECT support in fuse has been for quite some time now, surely well
before 3.4

On Fri, Feb 13, 2015, 02:37 Pedro Serotto <pedro.serotto at yahoo.es> wrote:

> Dear All,
> I am actually using the following software stack:
> debian wheezy with kernel 3.2.0-4-amd64, glusterfs 3.6.2, openstack Juno,
> libvirt 1.2.9.
> If I try to attach a block storage to a running vm, Openstack shows the
> following error:
> "DeviceIsBusy: The supplied device (vdc) is busy".
> If I try to attach a block storage to a running vm, Libvirt shows the
> following error:
>  "qemuMonitorTextAddDrive:2621 : operation failed: open disk image file
> failed"
> Looking up for this issue on the web, I found out that Libvirt tries to
> open the block device by using  O_DIRECT flag on; This last one is
> supported only by fuse for kernel >3.4.
> Therefore, I tried to apply some options (
> http://www.gluster.org/documentation/use_cases/Virt-store-usecase/) to
> Gluster, but the problem has not been solved.
> I also found  https://github.com/avati/liboindirect but it is old and not
> mantained.
> Does somebody found himself in the same situation? If yes, could you
> please show me how to solve it by mainteining the same version of my
> software stack.
> Thanks&Regards
> Pedro
> _______________________________________________
> Gluster-users mailing list
> Gluster-users at gluster.org
> http://www.gluster.org/mailman/listinfo/gluster-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.gluster.org/pipermail/gluster-users/attachments/20150213/18334f0d/attachment.html>

More information about the Gluster-users mailing list