[Gluster-users] O_DIRECT (I think) again

Pedro Serotto pedro.serotto at yahoo.es
Fri Feb 13 10:37:11 UTC 2015

Dear All,
I am actually using the following software stack:
debian wheezy with kernel 3.2.0-4-amd64, glusterfs 3.6.2, openstack Juno, libvirt 1.2.9.
If I try to attach a block storage to a running vm, Openstack shows the following error:   "DeviceIsBusy: The supplied device (vdc) is busy".
If I try to attach a block storage to a running vm, Libvirt shows the following error:  "qemuMonitorTextAddDrive:2621 : operation failed: open disk image file failed"
Looking up for this issue on the web, I found out that Libvirt tries to open the block device by using  O_DIRECT flag on; This last one is supported only by fuse for kernel >3.4.Therefore, I tried to apply some options (http://www.gluster.org/documentation/use_cases/Virt-store-usecase/) to Gluster, but the problem has not been solved.I also found  https://github.com/avati/liboindirect but it is old and not mantained.
Does somebody found himself in the same situation? If yes, could you please show me how to solve it by mainteining the same version of my software stack.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.gluster.org/pipermail/gluster-users/attachments/20150213/2b84b9c5/attachment.html>

More information about the Gluster-users mailing list