[Gluster-users] Gluster not recognizing available space

Brian Foster bfoster at redhat.com
Wed Feb 5 21:01:58 UTC 2014

On 02/05/2014 03:39 PM, Pat Haley wrote:
> Hi Brian,
> I tried both just using touch to create
> an empty file and copying a small (<1kb)
> file.  Neither worked.
> Note: currently the disk served by gluster-0-1
> is mounted as
> /dev/sdb1               /mseas-data-0-1         xfs     defaults        1 0
> I have received some advice to change the mount
> to  nobarrier,inode64,delaylog
> Would this be compatible with gluster?

That suggests XFS cannot allocate more inodes. inode64 is worth a try if
that is not currently enabled. I don't think it should make a difference
for gluster. The other options are unrelated and should have no effect.


> Pat
>> On 02/04/2014 02:14 PM, Jeff Darcy wrote:
>>>> I tried to "go behind" gluster and directly
>>>> write a file to the nfs filesystem on gluster-0-1.
>>>> If I try to write to /mseas-data-0-1 (the file
>>>> space served by gluster-0-1) directly I still
>>>> get the "No space left on device" error.
>>>> (df -h still shows 784G on that disk)
>> Are you writing to an existing file or attempting to create a new one?
>> Can you simply create a new, empty file on your backend (i.e., touch
>> mynewfile)?
>> Brian
>>>> If I try to write to the system disk
>>>> (the only other area) there is no problem.
>>>> I don't have any portion of the disk served by
>>>> gluster-0-1 that is not under gluster, so I
>>>> can't try to write to a non-gluster portion of
>>>> the disk.
>>>> Does this suggest anything?
>>> Quota limit?
>>> _______________________________________________
>>> Gluster-users mailing list
>>> Gluster-users at gluster.org
>>> http://supercolony.gluster.org/mailman/listinfo/gluster-users

More information about the Gluster-users mailing list