[Gluster-users] Folder disappeared on volume, but exists on bricks.

Susant Palai spalai at redhat.com
Tue Dec 2 15:58:35 UTC 2014

Hi Peter,
  I tried your scenario on my setup [deleted the directory on one of the brick{hashed}]. Hence, I don't see the directory on the mount point.
So what I tried is, created a fresh mount and sent a lookup on the missing directory name.

e.g /mnt/fresh is your new mount point. And /mnt/fresh/dir1/missing_dir is the missing directory.
What I did is "ls /mnt/fresh/dir1/missing_dir". And I could see the missing directory back on my mount point. [May be I am repeating the same thing again]

So what I will suggest here is do a new fuse mount and then send a lookup on the directory name. In case it does not work, we need to check the logs. 

Note: When you try this all of all bricks should be running, as healer will abort in case there is network disconnection from the server or a brick is down.


----- Original Message -----
From: "Peter B." <pb at das-werkstatt.com>
To: "Peter B." <pb at das-werkstatt.com>
Cc: gluster-users at gluster.org
Sent: Tuesday, 2 December, 2014 6:18:29 PM
Subject: Re: [Gluster-users] Folder disappeared on volume, but exists on bricks.

Am Di, 2.12.2014, 13:42 schrieb Peter B.:
> Sorry, but obviously I overlooked your reply before.
> When you say "existing mount", do you mean I should unmount/remount it -
> or should I rather create a new mount point, like e.g. "/mnt/test"?

I've now tried both, but the files still won't show up on the gluster
volume mount point.

I've done the following:
1) find a folder which exists on the bricks, but not on the volume.
2) ls -la /mnt/where_volume_is_mounted/path_to_folder/*


I tried the same with a single filename, including the full path of the
>>> Just to confirm, when you did ls on the file you meant the missing directory, right ?

Did I overlook anything?


Gluster-users mailing list
Gluster-users at gluster.org

More information about the Gluster-users mailing list