[Gluster-users] Fwd: Glusterfs denied mount

greg teddy frenchteddy at gmail.com
Fri Nov 22 04:40:12 UTC 2013

Thanks for your answer. The ouput of "gluster volume info" is:

Volume Name: ARCHIVE80
Type: Replicate
Volume ID: b06c9aa9-1763-43fa-884a-ed5d1ae34ceb
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Brick1: Server1:/home/ARCHIVE/sd3180
Brick2: Server2:/home/ARCHIVE/sd3180
Options Reconfigured:
nfs.disable: on
diagnostics.count-fop-hits: on
diagnostics.latency-measurement: on
auth.allow: *

I tried having "Server1,Server2,localhost" for "auth.allow", same result.

The output of "gluster peer status" is:

Number of Peers: 1

Hostname: Server2
Uuid: a4c55593-1d10-436f-afe0-2321efa3a85a
State: Peer in Cluster (Connected)

The mount commands tested are (on Server1):

mount -t glusterfs localhost:/ARCHIVE80 /mnt/ARCHIVE80/
mount -t glusterfs Server1:/ARCHIVE80 /mnt/ARCHIVE80/
mount -t glusterfs Server2:/ARCHIVE80 /mnt/ARCHIVE80/

I failed to see the difference between the two servers...


2013/11/20 Vijay Bellur <vbellur at redhat.com>
> Can you provide the output of:
> gluster volume info?
> Do you have any auth-allow/reject parameters set?
> -Vijay
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20131122/a61cc62f/attachment.html>

More information about the Gluster-users mailing list