[Gluster-users] A problem when mount glusterfs via NFS

Pranith Kumar K pkarampu at redhat.com
Mon Mar 25 17:01:58 UTC 2013

On 03/25/2013 08:23 AM, Pippo wrote:
> HI:
> I run glusterfs with four nodes, 2x2 Distributed-Replicate.
> I mounted it via fuse and did some test, it was ok.
> However when I mounted it via nfs, a problem was found:
> When I copied 200G files to the glusterfs, the glusterfs process in the server node(mounted by client) was killed because of OOM, 
> and all terminals of the client were hung. Trying to test for many times, I got the same result. The heavier load I pushed via the
> client, the faster glusterfs process been killed. I run "top" in the server, found that the glusterfs process eat MEM very fast, 
> and
> never gone down until it was killed. I think it is a bug of glusterfs process, it leak memory.
> I google "glusterfs OOM" but can not find any solutions. Is anyone know about this problem and give me some tips? Many thanks!
> ------------------------------------------------------------------------
> Pippo
> _______________________________________________
> Gluster-users mailing list
> Gluster-users at gluster.org
> http://supercolony.gluster.org/mailman/listinfo/gluster-users
         Could you let us know the version of glusterfs you were using? 
nfs server Logs of that run would help us if you could attach that to 
this mail.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20130325/b9141131/attachment.html>

More information about the Gluster-users mailing list