[Gluster-users] Can't get gluster to mount on boot

Marcus Bointon marcus at synchromedia.co.uk
Tue Mar 12 18:14:42 UTC 2013

This is something I've been trying to get to work for the last year or so, but have still not found a working solution.

I have two servers in a simple replication config of a single volume running gluster 3.3.0 (I'm avoiding 3.3.1 because of its known NFS issues) on Ubuntu Lucid. As well as hosting a gluster server, each mounts the gluster volume via NFS over tcp on localhost. There is also a third server that mounts the NFS volume but is not running any gluster code (client nor server), and that displays exactly the same symptoms, so I don't think running gluster server or accessing via localhost is causing the problem.

Firstly, a manual mount works fine, so I know that the NFS settings, paths, permissions and the gluster volume itself are ok.

If I try to mount via fstab (even with _netdev), it hangs the machine on boot and it must be put into single-user mode in order to restore it, so I'm not trying that approach for now.

This list suggested using autofs, so I've been trying that, with no success. I've created a /etc/auto.nfs file containing this:

/var/lib/sitedata/aegir -fstype=nfs,vers=3,hard,noexec,nosuid,nodev,rsize=32768,wsize=32768,intr,noatime,mountproto=tcp

and referred to it from /etc/auto.master, and commented out the '+auto.master' line, as suggested on docs I found (it doesn't work work either way). autofs does do *something* here, but it appears to completely ignore NFS and instead creates and rebinds /shared locally at /var/lib/sitedata/aegir. I've tried with a minimal options list (just -fstype=nfs,mountproto=tcp) but it doesn't help.

gluster peer status and gluster volume status both say all is present and correct with respect to the underlying gluster volume. The only anomaly I am seeing is this happening once per second in syslog:

Mar 12 17:09:49 web2 init: glusterd main process ended, respawning
Mar 12 17:09:50 web2 init: glusterd main process (20365) terminated with status 255

I've googled that and not found anything at all.

How does everyone else do automounts?

Marcus Bointon
Synchromedia Limited: Creators of http://www.smartmessages.net/
UK info at hand CRM solutions
marcus at synchromedia.co.uk | http://www.synchromedia.co.uk/

More information about the Gluster-users mailing list