[Gluster-users] Debugging gfapi

Jeff Darcy jdarcy at redhat.com
Wed Dec 18 17:54:55 UTC 2013

On 12/18/2013 10:23 AM, Kelly Burkhart wrote:
> Is there some trick I need to do to use gdb on libgfapi?  I
> configured gluster like this:
> ./configure --disable-ibverbs --enable-debug
> And also tried this:
> CFLAGS=-g CPPFLAGS=-g LDFLAGS=-g ./configure --disable-ibverbs
> --enable-debug
> I can't step into calls like glfs_new, the debugger skips over the
> call.  Is there some magic that makes gdb think that gfapi is not
> debuggable?

The formula for getting GlusterFS to build with the proper flags seems
to change frequently.  If you look at configure.ac the current magic
seems to be:

	export enable_debug=yes

That's what I do for my own build, and I'm generally able to step
through anything in a translator.  I haven't tried with gfapi, but it
should be the same because it's also a library.  Executables are a
different matter because they're explicitly stripped during the build

More information about the Gluster-users mailing list