[Gluster-users] Recovering a crashed node

Kelly Burkhart kelly.burkhart at gmail.com
Mon Dec 16 22:23:49 UTC 2013

How can I recover a lost node or disk in a cluster?

I have a four node cluster, each with a single brick.  I've created a
volume like so:

sudo gluster volume create gv0 stripe 2 replica 2 transport tcp \
  devlab06:/scratch/brick01 \
  devlab07:/scratch/brick01 \
  devlab08:/scratch/brick01 \
sudo gluster volume start gv0
gluster volume set gv0 cluster.stripe-block-size 134217728

I mounted this from another node, copied some large files to it then logged
into one of the nodes and "crashed" it by executing kill -9 on every
gluster process.  After this I was still able to read all data from the
cluster and verify via md5sum no issues.

I nuked all data in my "crashed" node and now have a completely empty
/scratch/brick01 directory, how do I integrate this into the volume?  I
tried the steps in the 'Gluster 3.2: Brick Restoration - Replace Crashed
Server' page, but that doesn't seem to apply to 3.4.1...  I also tried
simply removing the brick, but that failed.

Running /etc/init.d/glusterd start fails to start anything, but I can run
interactively via /usr/local/sbin/glusterd --no-daemon.

Thanks in advance for any assistance.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20131216/ac9ba694/attachment.html>

More information about the Gluster-users mailing list