[Gluster-users] Centos5.9 Fuse Client fails to write file with 'dd'

The Figuras thefiguras at gmail.com
Fri Aug 30 16:40:23 UTC 2013

Hello, Fellow Gluster Users

 I am testing writing file with 'dd' from FUSE client on Centos6 and
Centos5. Command syntax is i have used is:

/bin/dd if=/dev/zero of=/data/gluster/file bs=20M count=1 oflag=direct

   When I run it on Centos6 Client, I am receiving results as expected:

 1+0 records in
 1+0 records out
 20971520 bytes (21 MB) copied, 0.125189 s, 168 MB/s

  However, when I run the same command on CentOS5.9 I cant create a file.

/bin/dd: opening `/data/gluster/file': Invalid argument

  I can perform other operations such as copy or move onto FUSE mounted
director without any issues.

    Anyone else have seen similar behavior? My specs are below:

Client1: CentoOS 5.9(Final)2.6.18-348.16.1.el5.x84_64

Client2: CentOS 6.4(Final)2.6.32-358.el6.x86_64

Gluster Server: CentOS 6.4(Final) 2.6.32-358.14.1.el6.x86_64
Type: Distributed-Replicate
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20130830/513ec459/attachment.html>

More information about the Gluster-users mailing list