[Gluster-users] Error when creating volume

Bobby Jacob bobby.jacob at alshaya.com
Thu Aug 22 13:40:37 UTC 2013

Try using the following command :

setfattr -x trusted.glusterfs.volume-id /export/
setfattr -x trusted.gfid /export/

If this doesn't solve the problem, then I guess you will have to follow this attached email chain.

Thanks & Regards,
Bobby Jacob

From: gluster-users-bounces at gluster.org [mailto:gluster-users-bounces at gluster.org] On Behalf Of Olivier Desport
Sent: Thursday, August 22, 2013 4:31 PM
To: gluster-users at gluster.org
Subject: Re: [Gluster-users] Error when creating volume

Le 22/08/2013 15:07, Olivier Desport a écrit :

I've removed a volume and I can't re-create it :

gluster volume create gluster-export gluster-6:/export gluster-5:/export gluster-4:/export gluster-3:/export
/export or a prefix of it is already part of a volume

I've formatted the partition and reinstalled the 4 gluster servers and the error still appears.

Any idea ?

Some more informations :

I've formatted in OCFS2 and GlusterFS version is 3.3.1-1.

I've tried to set attributes with setfattr command but it still doesn't work.


Gluster-users mailing list

Gluster-users at gluster.org<mailto:Gluster-users at gluster.org>


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20130822/5c7f376c/attachment.html>
-------------- next part --------------
An embedded message was scrubbed...
From: "Stroppa Daniele (strp)" <strp at zhaw.ch>
Subject: Re: [Gluster-users] Volume creation fails with "prefix of it is
 already part of a volume"
Date: Thu, 22 Aug 2013 06:57:58 +0000
Size: 15745
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20130822/5c7f376c/attachment.mht>

More information about the Gluster-users mailing list