[Gluster-users] Volume creation fails with "prefix of it is already part of a volume"

Daniel Müller mueller at tropenklinik.de
Thu Aug 22 06:05:57 UTC 2013

There is another bug concerning 3.4. on Centos 6.4 .If you crate a
replicating vol there is sometimes that the glusterd.vol
is not created in /etc/glusterfs on one of the nodes. Than you have to copy
it over from one of the working nodes. 
Or you loose it on one host. Than do the same.

EDV Daniel Müller

Leitung EDV
Tropenklinik Paul-Lechler-Krankenhaus
Paul-Lechler-Str. 24
72076 Tübingen

Tel.: 07071/206-463, Fax: 07071/206-499
eMail: mueller at tropenklinik.de
Internet: www.tropenklinik.de
-----Ursprüngliche Nachricht-----
Von: Stroppa Daniele (strp) [mailto:strp at zhaw.ch] 
Gesendet: Mittwoch, 21. August 2013 16:52
An: mueller at tropenklinik.de; gluster-users at gluster.org
Betreff: Re: AW: [Gluster-users] Volume creation fails with "prefix of it is
already part of a volume"

Thanks Daniel.

I'm indeed running Gluster 3.4 on CentOS 6.4.

I've tried your suggestion, it does work for me too, but it's not an optimal

Maybe someone could shed some light on this behaviour?

Daniele Stroppa
Institute of Information Technology
Zürich University of Applied Sciences
http://www.cloudcomp.ch <http://www.cloudcomp.ch/>

On 21/08/2013 09:00, "Daniel Müller" <mueller at tropenklinik.de> wrote:

>Are you running with gluster 3.4?
>I had the same issue. I solved it by deleting my subfolders again and 
>then create new ones. In your case brick1 and brick2.
>Then create new subfolders in the place,ex.: mkdir /mnt/bricknew1  and
>/mnt/bricknew2 .
>This solved the problem for me, not knowing why gluster 3.4 behave like 
>Good Luck
>EDV Daniel Müller
>Leitung EDV
>Tropenklinik Paul-Lechler-Krankenhaus
>Paul-Lechler-Str. 24
>72076 Tübingen
>Tel.: 07071/206-463, Fax: 07071/206-499
>eMail: mueller at tropenklinik.de
>Internet: www.tropenklinik.de
>Von: gluster-users-bounces at gluster.org
>[mailto:gluster-users-bounces at gluster.org] Im Auftrag von Stroppa 
>Gesendet: Dienstag, 20. August 2013 21:51
>An: gluster-users at gluster.org
>Betreff: [Gluster-users] Volume creation fails with "prefix of it is 
>already part of a volume"
>Hi All,
>I'm setting up a small test cluster: 2 nodes (gluster-node1 and
>gluster-node4) with 2 bricks each (/mnt/brick1 and /mnt/brick2) and one 
>volume (vol_icclab). When I issue the create volume command I get the 
>following error:
># gluster volume create vol_icclab replica 2 transport tcp 
>volume create: vol_icclab: failed: /mnt/brick1/vol_icclab or a prefix 
>of it is already part of a volume
>I checked and found this [1], but in my case the issue it's happening 
>when creating the volume for the first time, not after removing/adding 
>a brick to a volume.
>Any suggestions?
>Daniele Stroppa
>Institute of Information Technology
>Zürich University of Applied Sciences

More information about the Gluster-users mailing list