[Gluster-users] cluster.min-free-disk not working

Thomas Wakefield twake at cola.iges.org
Mon Apr 15 18:48:30 UTC 2013

Was there ever a solution for setting min-free-disk?  I have a cluster of about 30 bricks, some are 8TB and new bricks are 50TB.  I should be able to set gluster to leave 500GB free on each brick.  But one of the 8TB bricks keeps filling up with new data.

This is my current setting:
cluster.min-free-disk: 500GB


Running 3.3.1.


On Aug 26, 2012, at 2:15 AM, James Kahn <jkahn at idea11.com.au> wrote:

> Further to my last email, I've been trying to find out why GlusterFS is
> favouring one brick over another. In pretty much all of my tests gluster
> is favouring the MOST full brick to write to. This is not a good thing
> when the most full brick has less than 200GB free and I need to write a
> huge file to it.
> I've set cluster.min-free-disk on the volume, and it doesn't seem to have
> an effect. At all. I've tried setting it to 25%, and 400GB. When I run
> tests from an NFS client, they get written to the most full brick. There
> is less than 10% free on that brick so it should be ignore with the
> defaults anyway.
> Any ideas?
> JK
> _______________________________________________
> Gluster-users mailing list
> Gluster-users at gluster.org
> http://gluster.org/cgi-bin/mailman/listinfo/gluster-users

More information about the Gluster-users mailing list