[Gluster-users] Troubleshooting Unified Object and File Storage in 3.3

Jason Brooks jbrooks at redhat.com
Wed Jun 6 21:52:35 UTC 2012

Hi everyone,

I've been working on testing UFO in Gluster 3.3, but I've had a hard
time getting it working. I've been following along with the admin guide
on chapter 12.

I've been testing on CentOS 6.2. The only command from the Admin guide
I've run successfully has been: curl -v -H 'X-Storage-User: test:tester'
-H 'X-Storage-Pass:testing' -k

I started out with a centos machine running gluster-swift, which I was
connecting to a four node gluster cluster. It wasn't clear to me from
the admin guide where I was supposed to mount my gluster volume, so I've
tried various permutations, including mounting it at the location
specified in the /etc/swift/fs.conf file, with a symlink to the
/srv/1/node location cited in the 1.conf files provided by the
gluster-swift-plugin package.

I also tried creating a gluster volume on the same server as the
gluster-swift, but that didn't work for me, either.

Is there a better source of docs than the admin guide? I'll be happy to
help write this up once I get everything working.

One more thing, the 3.3 admin guide talks about downloading the 3.2
version of gluster-swift and gluster-swift-plugin -- I'd assumed that
that was a typo, and I've been working with the packages from 3.3, but
maybe I was wrong there -- are the 3.2 packages the right ones?

Thanks, Jason

More information about the Gluster-users mailing list