[Gluster-users] Gluster 3.3.0 doesn't see neighbour

Vladimir Yakovlev mrquesty at gmail.com
Mon Jul 2 11:32:44 UTC 2012

Hi Everyone,

I'm trying to set up Gluster 3.3.0 on a fresh CentOS 6.2 with selinux &
firewall disabled, hosts can see each other (they are present in DNS and
one can ping/telnet to gluster port each other), there seems to be nothing
suspicious in sysctl, but whatever I put in peer probe refers to "Probe on
localhost not needed".

Configurations follow:
#cat /etc/glusterfs/glusterd.vol
volume management
    type mgmt/glusterd
    option working-directory /var/lib/glusterd
    option transport-type tcp #to use IPv4
    option transport.socket.keepalive-time 10
    option transport.socket.keepalive-interval 2
    option transport.socket.read-fail-log off

# cat /etc/nsswitch.conf
#hosts:     db files nisplus nis dns
hosts:      files dns

# cat /etc/sysconfig/iptables
# Firewall configuration written by system-config-firewall
# Manual customization of this file is not recommended.

[root at host1 ~]# nc host2 24007

[root at host1 ~]# ping -c5 host2
PING host2 ( 56(84) bytes of data.
64 bytes from host2 ( icmp_seq=1 ttl=64 time=0.679 ms
64 bytes from host2 ( icmp_seq=2 ttl=64 time=0.656 ms
64 bytes from host2 ( icmp_seq=5 ttl=64 time=0.671 ms

--- host2 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4000ms
rtt min/avg/max/mdev = 0.656/0.673/0.704/0.024 ms

and vice versa.

I tried to put Gluster in debug mode, but it didn't provide more details.
I also tried to put entries to /etc/hosts for both machines, but it didn't
help either.

Does anyone know, what can be the root cause?

Any help would be very much appreciated.

Thank you in advance,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20120702/c2966597/attachment.html>

More information about the Gluster-users mailing list