[Gluster-users] Fwd: deleted files not giving space back

Gerald Brandt gbr at majentis.com
Wed Apr 25 11:42:23 UTC 2012

----- Original Message -----
> From: "Rodrigo Severo" <rodrigo at fabricadeideias.com>
> To: "Gerald Brandt" <gbr at majentis.com>
> Cc: "gluster-users" <gluster-users at gluster.org>
> Sent: Wednesday, April 25, 2012 6:37:13 AM
> Subject: Re: [Gluster-users] Fwd: deleted files not giving space back
> On Wed, Apr 25, 2012 at 8:03 AM, Gerald Brandt < gbr at majentis.com >
> wrote:
> Can anyone answer the question below?
> ----- Forwarded Message -----
> From: "Gerald Brandt" < gbr at majentis.com >
> To: "gluster-users" < gluster-users at gluster.org >
> Sent: Monday, April 23, 2012 12:39:02 PM
> Subject: [Gluster-users] deleted files not giving space back
> Hi,
> I'm running 3.2.5 on Ubuntu 10.04. I have a USB drive that stores
> rotating snapshots of our VM's, and I keep 2 days of snapshots on
> the drive.
> Every night a cron job runs and deletes the oldest snapshots off the
> drive. After a few days, the gluster mount, and it's base drive,
> show 100% full. If I go into the gluster mount, a du -sh shows the
> drive to be about 50% full.
> If I unmount the gluster mount, restart glusterd, and remount the
> gluster mount, everything goes back to normal.
> At first I tried to just unmount the gluster mount, and then unmount
> the physical drive. I couldn't unmmount the physical drive, it was
> in use. An lsof got me the attached file. Each of the .xva files are
> files that were deleted. An ls didn't show them on the disk, and a
> du didn't count their size. Does anyone know why the files are still
> actively open?
> I can't say why but I bet it has nothing to do with gluster. Try to
> look at this issue as if there was no gluster involved.
> I don't know what kind of application creates .xva files but does
> this application really releases the files? How are you deleting
> them? What user/application lsof says is hiding the files? Aren't
> you accessing the files directly on the bricks somehow?
> Rodrigo Severo

I'm going to have to disagree.  The previous set up used Samba as the share instead of Gluster, and it worked perfectly.  The only change was the export type (Samba vs Gluster/NFS)


More information about the Gluster-users mailing list