[Gluster-users] unable to remove brick / stop volume in glusterfs 3.2

Neetu Ojha neetuojha.cdac at gmail.com
Tue Oct 18 09:14:02 UTC 2011


  I have installed glusterfs 3.2 on two nodes.Volumes are created for rdma.
I tested the glusterfs with volume of replica type. But now wanted to test
for stripe mode and so now i am trying to reconfigure the volume.

I unmounted all clients then restarted the glusterd on all the nodes. After
that tried to stop the volume and also tried to remove the brick.That
resulted in error mesage: invalid operation.

One experience I would also like to share is that on the node on which the
brick's relevant file system was present resulted in the message
Incorrect brick for volume

Kindly suggest how to reconfigure the volume foer other type. Presently
gluster volume on my nodes are configured as replica type for >RDMA. I want
to reconfigure the volume for stripe mode.

 Thanks In advance

Neetu Sharma
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20111018/b51a594c/attachment.html>

More information about the Gluster-users mailing list