[Gluster-users] 3.1.2 feedback

Marcus Bointon marcus at synchromedia.co.uk
Fri Jan 21 14:16:57 UTC 2011

On 21 Jan 2011, at 14:37, Vijay Bellur wrote:

> Can you please elaborate a bit more about the rsync problem?

I'm keeping user-uploaded/created web content on a gluster volume. On one of the gluster nodes I run an hourly script to rsync the entire contents to another server. I get errors like this:

file has vanished: "/var/www/mysite/content/username/images/image.gif"
rsync warning: some files vanished before they could be transferred (code 24) at main.c(1060) [sender=3.0.7]
run-parts: /etc/cron.hourly/content-backup exited with return code 24

(the gluster volume is mounted at /var/www/mysite/content)

The errors are intermittent - some hours it works, other hours it doesn't. When I hit the URL that points at it, it seems to be fine. To fix it, I copy the file from its location on the gluster volume to somewhere else, then copy it back. So far this has always fixed the problem. I originally started seeing this with gluster 3.0 and it's persisted with 3.1.x.

It's possible that some files have indeed vanished between rsync creating its list and actually copying it (for example cache files created by wp-supercache are often very short-lived), however, this is mostly not the case - I'll often get the same error for the same file for several consecutive hours.

I suspect this could be a metadata issue of some kind -  if you can tell me how, I can grab some kind of metadata dump from the affected files on both my backing stores and through the mounted gluster volume.


More information about the Gluster-users mailing list