[Gluster-users] GlusterFS client on openSUSE 11.3 x86_64

Bernard Li bernard at vanhpc.org
Tue Sep 21 21:35:55 UTC 2010

Hi guys:

On Mon, Sep 20, 2010 at 11:02 PM, Amar Tumballi <amar at gluster.com> wrote:

> Also check if your build msgs have '-fstack-protection' flag set.. if yes,
> please build with 'CFLAGS="-fno-stack-protection' flag and it should work
> fine.

Thanks for the suggestions, but turns out it wasn't stack-protection


On openSUSE 11.3, the optflags/CFLAGS in /usr/lib/rpm/rpmrc has the following:

x86_64 -O2 -g -m64 -fmessage-length=0 -D_FORTIFY_SOURCE=2
-fstack-protector -funwind-tables -fasynchronous-unwind-tables

by changing -D_FORTIFY_SOURCE=2 to -D_FORTIFY_SOURCE=1 in the local
.rpmrc file, the resulting RPM works fine.

Is this something that could be worked around in the code?  Should I file a bug?

P.S. When I run glusterfs --debug -f and hit Ctrl-C to exit the
program, it would leave a stale mount, is this a feature or bug?



More information about the Gluster-users mailing list