[Gluster-users] hanging "df" (3.1, infiniband)

Lana Deere lana.deere at gmail.com
Tue Oct 19 15:59:32 UTC 2010

I tried to install 3.1 on some machines but I have run into trouble.

I have 4 nodes I'm using for storage in a distributed configuration.
    # gluster volume info

    Volume Name: RaidData
    Type: Distribute
    Status: Started
    Number of Bricks: 4
    Transport-type: rdma
    Brick1: storage0:/data
    Brick2: storage1:/data
    Brick3: storage2:/data
    Brick4: storage3:/data

When I try to mount the volume on another machine,
  A. If I forget to modprobe fuse first, the mount command reports no errors
     but no volume is listed in the mount table.  (I.e., "mount -t..." seems
     to work, but "mount" doesn't show any volumes.)
  B. If I remember to modprobe fuse first, again the mount command reports
     no errors and this time I can see the volume in the mount table.
        # mount
        /dev/sda1 on / type ext3 (rw)
        glusterfs#storage0:/RaidData on /mnt/RaidData type fuse
    However, if I do a "df" or try to "cd" to that volume, the command
hangs without
    printing any messages.

    I wasn't sure if I needed to specify "-o transport=rdma" on the
mount command
    so I tried it both ways, but with no apparent difference.

Anyone have suggestions for things to try?  Do I need to have IPoIB
running on all the nodes?


.. Lana (lana.deere at gmail.com)

More information about the Gluster-users mailing list