[Gluster-users] Failure to copy read-only files to gluster volume

isdtor isdtor at gmail.com
Tue Nov 30 11:20:01 UTC 2010

Both glusterfs 3.1.0 and 3.1.1 exhibit the following behaviour:

$  df -Th .
Filesystem    Type    Size  Used Avail Use% Mounted on
              fuse     54T  222G   53T   1% /mnt/data
$  ls -l /bin/ps
-r-xr-xr-x 1 root root 83696 Jan 21  2009 /bin/ps
$  ls -l /bin/ls
-rwxr-xr-x 1 root root 91240 Mar  1  2010 /bin/ls
$  cp -p /bin/ps /bin/ls .
cp: closing `./ps': Permission denied
$  ls -l
total 104
-rwxr-xr-x 1 myuser mygroup 91240 Mar  1  2010 ls
-r-xr-xr-x 1 myuser mygroup     0 Jan 21  2009 ps

This works when executed as root.

Gluster server platform is CentOS 5.5, the client is running CentOS
5.4. I have tried this with an updated fuse module on the
client, i.e. Gluster's fuse patches applied to CentOS 5.4's fuse
module, with the same result. I cannot tell whether the bug is
in Glusterfs or fuse. The gluster filesystem is mounted via automount.

More information about the Gluster-users mailing list