[Gluster-users] Problems with Gluster 3.1 and quick-read translator

Hugo Cisneiros (Eitch) hugo.cisneiros at gmail.com
Thu Nov 18 17:35:22 UTC 2010


I updated an installation of Gluster from 3.0.5 to 3.1 and got some
problems using the quick-read translator.

The setup is 1 brick on 2 servers as replica, created with:

gluster volume create testing replica 2 transport tcp
gluster volume start testing

Then I used the testing-fuse.vol created at /etc/glusterd/vols/testing
on two clients. The file includes the quick-read translator (that I
used to use on 3.0.5). In this setup, I could mount, read and write
files/directories into the gluster volume.

But, when I edit one small file (11k) in client 1, client 2 does not
see the update to the file. Since directory updates
(creating/renaming/removing files) were working, I began setting
different cache timeouts on performance.cache-timeout and quick-read's
timeout option. Neither worked. I also used the old client
configuration from 3.0.5 that was working fine. Same thing: everything
worked, but the updates on small files weren't.

So I disabled the quick-read translator on the client configuration
and updates began to work imeediately. Since its not critical to have
this translator for me, I'll continue to use the clients without it.

But is this a bug or something expected? :)



More information about the Gluster-users mailing list