[Gluster-users] Replication deleting file contents

Vikas Gorur vikas at gluster.com
Fri Dec 18 11:40:44 UTC 2009

Adrian Revill wrote:
> Hi
> I have read through the docs and google and I think i am trying to do 
> this right, but just wanted to be sure i have it correctly configured.
> I have 2 servers factory1 and factory2, both clean installs of RHEL5.4 
> on basic hardware.
> I followed the instructions from 
> http://gluster.com/community/documentation/index.php/GlusterFS_User_Guide, 
> and have installed 3.0.0-1
> On factory1 I ran the command
> /usr/bin/glusterfs-volgen --name dataexp --raid 1 
> factory1:/data/export factory2:/data/export
> I copied factory1-dataexp-export.vol to /etc/glusterfsd.vol on factory1
> factory2-dataexp-export.vol to /etc/glusterfsd.vol on factory2
> and coppied dataexp-tcp.vol to /etc/glusterfs.vol on both factory1 and 
> factory2
> Then on both servers I started the server with the init script and ran
> mount -t glusterfs /etc/glusterfs/glusterfs.vol /mnt/export
> Every thing works fine, i can copy files into either servers 
> /mnt/export directory and they appear on the other server.
> I then tried a failure scenario. With both servers and clients up i 
> deleted all the files from /mnt/export, so far so good.
> I then shut down the server on factory1, leaving the client up and 
> copied three large files (715MB each) into /mnt/export on factory2
> Both factory1 and factroy2 both show the files with the correct size 
> and md5sum.
> I then started the server on factory1.
> This is where it goes wrong, as soon as factory1 starts, both clients 
> show the file sizes of the files as 0, checking the backing store 
> /data/export i see the files are also 0 size there too. The md5Sum is 
> now wrong.
> It seems that the replication has created the files on factory2, but 
> before copying the contents, it has decided that the empty files on 
> factory1 are newer than factory2 and decided to copy the zero size 
> files back to factory1.
> Any one got any ideas?
Adrian, If this is reproducible easily, can you run the clients with log 
level TRACE and send us the logs (or perhaps log a bug and attach it 
there if they are big)?


More information about the Gluster-users mailing list