[Gluster-users] Can't get gluster running on 64bit Suse 10.1 system

Andrew Burkett burkett.andrew at gmail.com
Wed Jun 25 23:57:30 UTC 2008

Thanks for the help.  It seems everytime I try to install new software, I
learn new things about the way linux works.

(If someone else comes across this issue, running "ldconfig -p" will list
all the libraries found by ldconfig.  Then you can check to see if
libfuse.so and libgluster.so have been found by running ldconfig.)


On Tue, Jun 24, 2008 at 3:30 PM, Amar S. Tumballi <amar at zresearch.com>

> Its mostly the PATH issue.
> try adding '/usr/local/lib' in /etc/ld.so.conf, and run ldconfig. It should
> work fine. (make sure you build GlusterFS again with proper libfuse.so,
> which should be detected after running ldconfig).
> Or you can choose to give 'LDFLAGS=-L/usr/local/lib' (or is it
> '-L/usr/local/lib64') for make.
> Regards,
> Amar
> 2008/6/24 Andrew Burkett <burkett.andrew at gmail.com>:
>> I'm trying to get gluster going on the system mentioned in the title and
>> I'm have two issues.  The fuse mod compiles and installs just fine, or so it
>> says.  But when I run configure for glusterfs the summary at the end says
>> that its not configuring for FUSE client support.  Both the stock kernel
>> fuse and the modded one are on the computer, but its not recognizing them.
>> Also ignoring the client capabilities, when I run the glusterfsd to set up
>> a server, I get the following message with nothing being dumped into the log
>> file even will DEBUG loglevel set:
>> "error while loading shared libraries: libglusterfs.so.0 cannot open
>> shared object file: No such file or directory"
>> My guess is both of the issues are related to gluster looking in the wrong
>> place for the files.  Is there any flag that I can use for configure or make
>> that can fix this issue?
>> I'm using the commands shown in the installation tutorial, which worked
>> for a 32 bit Suse 10.1 system, so its probably somehow related to the system
>> being 64 bit.
>> Thank you for any help
>> _______________________________________________
>> Gluster-users mailing list
>> Gluster-users at gluster.org
>> http://zresearch.com/cgi-bin/mailman/listinfo/gluster-users
> --
> Amar Tumballi
> Gluster/GlusterFS Hacker
> [bulde on #gluster/irc.gnu.org]
> http://www.zresearch.com - Commoditizing Super Storage!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20080625/4a8e9148/attachment.html>

More information about the Gluster-users mailing list