[Gluster-users] GlusterFS startup problems

Pinoy Hatdog pinoy.hatdog at gmail.com
Sun Jun 8 15:57:03 UTC 2008

Hi Chris,

Well, I did try looking for '*fuse.so*' in the '*
/usr/lib/glusterfs/1.3.9/xlator/mount/*' directory, but I wasn't able to
find it there (actually the '*mount*' folder itself didn't even exist). So
that made me want to try doing another rebuild of GlusterFS (just in case
something was missed that I didn't notice), but that didn't help since the '
*mount*' folder was still missing after the rebuild.

Oh, also thanks for letting me know about forwarding it to the list, I only
just noticed that I was only sending my replies directly to you, and not to
the list.


On Sun, Jun 8, 2008 at 11:10 PM, Christopher Hawkins <chawkins at bplinux.com>

>  Sounds like it can't find fuse.so. Is it there?
> Also, be sure to copy the list and not just me. Others can help you as well
> and may know the exact cause of your problem.   ;-)
> -- Chris
>  ------------------------------
> *From:* Pinoy Hatdog [mailto:pinoy.hatdog at gmail.com]
> *Sent:* Sunday, June 08, 2008 4:10 AM
> *To:* Christopher Hawkins
> *Subject:* Re: [Gluster-users] GlusterFS startup problems
> Hi Christopher,
> Thanks again for the speedy response. I've tried starting a basic setup
> again, though still no success. After going through the logs, here's the
> message I found from the client terminal:
> 2008-06-08 15:53:40 E [xlator.c:120:xlator_set_type] xlator:
>> dlopen(/usr/lib/glusterfs/1.3.9/xlator/mount/fuse.so):
>> /usr/lib/glusterfs/1.3.9/xlator/mount/fuse.so: cannot open shared object
>> file: No such file or directory
>> TLA Repo Revision: glusterfs--mainline--2.5--patch-770
>> Time : 2008-06-08 15:53:40
>> Signal Number : 11
>> /usr/sbin/glusterfs -f /etc/glusterfs/glusterfs-client.vol -l
>> /usr/var/log/glusterfs/glusterfs.log -L WARNING /mnt/glusterfs
>> [0x110420]
>> /lib/libc.so.6(__libc_start_main+0xe0)[0x8c3390]
>> [glusterfs][0x80493c1]
> As for the server terminal, there were no errors in the log, so apparently
> this seems to be something that's limited to the client only.
> Thanks again.
> -Paul
> On Sun, Jun 8, 2008 at 1:19 PM, Christopher Hawkins <chawkins at bplinux.com>
> wrote:
>>  The directory where you will be mounting the gluster filesystem has to
>> exist beforehand (just like mounting a cd, or NFS, etc.). First create
>> /mnt/glusterfs and then try mounting it to that directory. Also, I'd expect
>> glusterfs to log something like that, even if it doesn't throw an error when
>> you tried to mount it. Check the gluster logs (and /var/log/messages) for
>> any errors. I think by default they are in /var/log/glusterfs/glusterfs.log
>>  ------------------------------
>> *From:* Pinoy Hatdog [mailto:pinoy.hatdog at gmail.com]
>> *Sent:* Sunday, June 08, 2008 1:13 AM
>> *To:* Christopher Hawkins
>> *Subject:* Re: [Gluster-users] GlusterFS startup problems
>>   Hello Christopher,
>> Thanks for the quick response. After following your instructions, I was
>> able to find the executable in the /usr/sbin/ folder. So what I did was to
>> try to start a basic setup based on the instructions on the *Install and
>> run GlusterFS v1.3 in 10mins<http://gluster.org/docs/index.php/Install_and_run_GlusterFS_v1.3_in_10mins>
>> * page. I made the corresponding volume spec file for both the server and
>> client, and then ran the following command on the server (just an addition,
>> iptables have already been disabled beforehand):
>> *
>> * *#* /usr/sbin/glusterfsd -f /etc/glusterfs/glusterfs-server.vol
>> And the following command on the client:*
>> * *#* /usr/sbin/glusterfs -f /etc/glusterfs/glusterfs-client.vol
>> /mnt/glusterfs
>> After I executed the GlusterFS startup commands on the server and client
>> terminals, I received no messages, so I understood that it had indeed
>> started successfully. However, when I checked on the client terminal to see
>> if there indeed was a /mnt/glusterfs directory, I was not able to find any.
>> -Paul
>> On Sun, Jun 8, 2008 at 11:50 AM, Christopher Hawkins <
>> chawkins at bplinux.com> wrote:
>>>  If you run 'updatedb' and then 'locate glusterfs', does it find the
>>> executable? Perhaps you didn't run 'make install' after you compiled?
>>>  ------------------------------
>>> *From:* gluster-users-bounces at gluster.org [mailto:
>>> gluster-users-bounces at gluster.org] *On Behalf Of *Pinoy Hatdog
>>> *Sent:* Saturday, June 07, 2008 10:33 PM
>>> *To:* gluster-users at gluster.org
>>> *Subject:* [Gluster-users] GlusterFS startup problems
>>>   Hello, I'm quite new to GlusterFS. Recently I tried to install
>>> GlusterFS based on the instructions found in the *Install and run
>>> GlusterFS v1.3 in 10mins<http://www.gluster.org/docs/index.php/Install_and_run_GlusterFS_v1.3_in_10mins>
>>> * page in the wiki. After installation, I tried to execute GlusterFS by
>>> entering the following command: '*glusterfs --help*', wherein I received
>>> the message that the glusterfs command could not be found.
>>> Just in case it is needed, I am using Fedora 8 distro for GlusterFS, and
>>> I have verified that I have installed all the needed requirements for
>>> installing GlusterFS (the build process also produced no errors whatsoever).
>>> Thanks in advance.
>>> -Paul
>>> _______________________________________________
>>> Gluster-users mailing list
>>> Gluster-users at gluster.org
>>> http://zresearch.com/cgi-bin/mailman/listinfo/gluster-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20080608/789d485d/attachment.html>

More information about the Gluster-users mailing list