[Gluster-users] FYI: lighttpd w. libglusterclient stopped working

Raghavendra G raghavendra at zresearch.com
Fri Dec 5 12:11:55 UTC 2008


can you run ldd on mod_glusterfs.so and check mod_glusterfs.so is indeed
linking to correct version of libglusterfsclient.so? Also can you send
server and client side logs?


On Thu, Dec 4, 2008 at 2:15 PM, Dan Larsen <dan at relax.dk> wrote:

> Hi,
> this is just to make sure, that you know of this problem and maybe
> help somebody having the same problem.
> I wanted to try out the glusterfs with lighttpd.
> I downloaded 1.4.0pre13 and followed the instructions.
> I constantly got the following errors from the glusterfs log:
> 2008-12-04 10:11:08 E [client-protocol.c:4790:client_setvolume_cbk]
> machinename: SETVOLUME on remote-host failed: ret=-2 error=Invalid
> argument
> 2008-12-04 10:11:08 E [dict.c:2183:dict_unserialize] dict: undersized
> buffer passsed
> then i tried the same thing, on a different server and got the same
> error.
> I then tried to downgrade to 1.4.0pre7 - that solved the problem!
> I have no idea, whether this is caused by 1.4.0pre13 libglusterfs*
> trying to access a gluster running 1.4.0pre7
> or whether it is a bug in 1.4.0pre13 - but now you know ;-)
> Best regards
> Dan Larsen
> _______________________________________________
> Gluster-users mailing list
> Gluster-users at gluster.org
> http://zresearch.com/cgi-bin/mailman/listinfo/gluster-users

Raghavendra G
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20081205/af3716c0/attachment.html>

More information about the Gluster-users mailing list