[Gluster-devel] Assistance setting up Gluster

Barak Sason sason922 at gmail.com
Mon Jul 22 09:09:18 UTC 2019

Greeting Yaniv,

Thank you very much for your response.

As you suggested, I'm installing additional VM (CentOs) on which I'll try
to use the repo you suggested in order to get Gluster up and running. I'll
update on progress in this matter later today, as it'll take a bit of time
to get the VM ready.

In addition, I'll post the RHEL problem in a separate thread, as you

In the meantime, let's focus on the Ubuntu problem.
I'm attaching the log file from Ubuntu, corresponding to running 'sudo
glusterd' command (attachment - glusterd.log).
Regarding you question about running manually - I've followed the
instructions specified in the INSTALL.txt file which comes with the repo
and specifies the following steps for installation:
1- ./autogen.sh
2- ./configure
3- make install
Please let me know if this somehow incorrect.

I kindly thank you for your time and effort,


On Mon, Jul 22, 2019 at 8:10 AM Yaniv Kaul <ykaul at redhat.com> wrote:

> On Mon, Jul 22, 2019 at 1:20 AM Barak Sason <sason922 at gmail.com> wrote:
>> Hello everyone,
>> My name is Barak and I'll soon be joining the Gluster development team as
>> a part of Red Hat.
> Hello and welcome to the Gluster community.
>> As a preparation for my upcoming employment I've been trying to get
>> Gluster up and running on my system, but came across some technical
>> difficulties.
>> I'll appreciate any assistance you may provide.
>> I have 2 VMs on my PC - Ubuntu 18, which I used for previous development
>> and RHEL 8 which I installed a fresh copy just days ago.
> 2 VMs is really minimal. You should use more.
>> The copy of Gluster code I'm working with is a clone of the master
>> repository.
>> On Ubuntu installation completed, but running the command 'sudo glusterd'
>> does nothing. Debugging with gdb shows that the program terminates very
>> early due to an error.
>> At glusterfsd.c:2878 (main method) there is a call to 'daemonize' method.
>> at glusterfsd.c:2568 a call to sys_read fails with errno 17.
>> I'm unsure why this happens and I was unable to solve this.
>> I've tried to run 'sudo glusterd -N' in order to deactivate
>> deamonization, but this also fails at glusterfsd.c:2712
>> ('glusterfs_process_volfp' method). I was unable to solve this issue too.
>> On RHEL, running ./configure results in an error regarding 'rpcgen'.
>> Running ./configure --without-libtirp was unhelpful and results in the
>> same error.
> I'd separate the two issues to two different email threads, as they may or
> may not be related.
> Please provide logs for each.
> Why are you running glusterd manually, btw?
> You may want to take a look at https://github.com/mykaul/vg - which is a
> simple way to set up Gluster on CentOS 7 VMs for testing. I have not tried
> it for some time - let me know how it works for you.
> Y.
>> As of right now I'm unable to proceed so I ask for your assistance.
>> Thank you all very much.
>> _______________________________________________
>> Community Meeting Calendar:
>> APAC Schedule -
>> Every 2nd and 4th Tuesday at 11:30 AM IST
>> Bridge: https://bluejeans.com/836554017
>> NA/EMEA Schedule -
>> Every 1st and 3rd Tuesday at 01:00 PM EDT
>> Bridge: https://bluejeans.com/486278655
>> Gluster-devel mailing list
>> Gluster-devel at gluster.org
>> https://lists.gluster.org/mailman/listinfo/gluster-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gluster.org/pipermail/gluster-devel/attachments/20190722/85f0d634/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: glusterd.log
Type: application/octet-stream
Size: 2055 bytes
Desc: not available
URL: <http://lists.gluster.org/pipermail/gluster-devel/attachments/20190722/85f0d634/attachment-0001.obj>

More information about the Gluster-devel mailing list