[Gluster-devel] Changing DISTAF 'global_mode' variable name
nigelb at redhat.com
Wed Jun 22 05:42:56 UTC 2016
On Tue, Jun 21, 2016 at 09:14:58PM +0530, M S Vishwanath Bhat wrote:
> On 21 June 2016 at 12:38, shwetha <spandura at redhat.com> wrote:
> > Hi,
> > Distaf test framework currently uses a variable 'global_mode' which is for
> > selecting the mode in which the tests runs.
> > When 'global_mode' is set to 'True' we run the tests with the config file
> > configuration and ignores 'runs_on_volumes', 'runs_on_protocols'.
> > When 'global_mode' is set to 'False' we use the configs "runs_on_volumes"
> > , "runs_on_protocols", reuse_setup as specified in the doc_string or
> > run_on_all_vols /run_on_all_protocols/reuse_setup:true if doc_string not
> > specified , to automatically loop through all the specified configs.
> > 'global_mode' is not self-explanatory on what it does. Hence it would be a
> > good idea to change the name to something more appropriate.
> > It can be changed to 'ignore_auto_configs'. When 'ignore_auto_configs' is
> > 'True' we run the tests with config file configurations. When
> > 'ignore_auto_configs' is set to 'False' we use the configs as specified in
> > doc_string.
This is great. +1
> > This is one option. If any one else has more appropriate name to use
> > please do suggest.
> Well, I am going to suggest the same thing which I suggested before... "
> *Iterative_mode*" or "iteration"
> The rational is simple. The 'global_mode' (as it is today) does loop
> through the possible (and permitted) volume type + mount protocol. Or in
> other words, it executes each test by iterating though the gluster volume
> and mount types. So in my mind it makes sense to have the flag as
> Also this is exactly one part of distaf which makes it pretty much tied to
> glusterfs automation. Because of the iteration distaf does over gluster
> volume type and guster mount protocols when flag is unset. So setting this
> flag makes it gluster independent ( more or less, still not completely). So
> keeping that in mind, we can also call it "*gluster_iterative_mode*" or "
> *gluster_iteration*" as well.
This still doesn't help with making it more self explanatory. If you know the
inner workings, it makes sense. Doesn't make it a lot better than
`global_mode`, I think.
> Best Regards,
> > Regards,
> > Shwetha
> > _______________________________________________
> > Gluster-devel mailing list
> > Gluster-devel at gluster.org
> > http://www.gluster.org/mailman/listinfo/gluster-devel
> Gluster-devel mailing list
> Gluster-devel at gluster.org
More information about the Gluster-devel